Difference between revisions of "Wx Interface"

From OpenKore Wiki
Jump to: navigation, search
m
m (Requirements)
Line 1: Line 1:
Wx interface is a cross-platform graphical user interface.
 
 
== Features ==
 
 
* dialogs for OpenKore prompts (connection settings, errors, [[wx_captcha|captcha]])
 
* OpenKore console
 
* chat log
 
* general input box for [[Console Commands]] input, chat and private messaging
 
* combined player, monster, NPC and item list (click and double click for various actions)
 
* map with field, players, monsters, NPCs and portals, with name and HP display (click to move and activate objects, mousewheel to zoom)
 
* config editor with categories and manual
 
* character, homunculus, mercenary and pet status windows with controls for various actions
 
* inventory, cart and storage lists with menu for item manipulation
 
* emotions window
 
 
 
== Requirements ==
 
== Requirements ==
  
{|class="gallery"
+
{|border="1" cellpadding="2" cellspacing="1"  
|-
+
|- style=background-color:#F9F9F9;
 
!OS/distribution
 
!OS/distribution
 
!Instructions
 
!Instructions
 
|-
 
|-
|align=center|FreeBSD
+
|align=center|FreeBSD
|Open a terminal, and type:
+
|Open a terminal and type:
 
  su -c 'pkg_add -r p5-Wx'
 
  su -c 'pkg_add -r p5-Wx'
 +
|-
 +
|align=center|Ubuntu
 +
|First, search for the libgtk package using the package manager.
 +
Open a terminal and type:
 +
apt-cache search libgtk
 +
Then install the latest version with this command:
 +
sudo apt-get install libgtkx-dev
 +
Where 'x' is the version number as found by the 'apt-cache search' command.
 +
 +
Lastly install the Wx cpan module with this command:
 +
sudo cpan Wx
 
|-
 
|-
 
|align=center|Other
 
|align=center|Other

Revision as of 14:05, 19 May 2010

Requirements

OS/distribution Instructions
FreeBSD Open a terminal and type:
su -c 'pkg_add -r p5-Wx'
Ubuntu First, search for the libgtk package using the package manager.

Open a terminal and type:

apt-cache search libgtk

Then install the latest version with this command:

sudo apt-get install libgtkx-dev

Where 'x' is the version number as found by the 'apt-cache search' command.

Lastly install the Wx cpan module with this command:

sudo cpan Wx
Other Open a terminal, and type:
cpan Wx